This issue has been resolved, and services are operating normally.
We apologize for any inconvenience this may have caused and appreciate your patience while we worked to address it.
Posted Sep 02, 2026 - 12:24 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 02, 2026 - 12:19 EDT
Update
We have further identified the impact as causing slower-than-normal search results on pages such as Patient Search.
While our technical team works to resolve the issue, you may improve search performance by using the available search filters to narrow your results.
Posted Sep 02, 2026 - 12:10 EDT
Identified
Agencies have reported system slowness issues in the HHAeXchange system today. The technical team is aware and working to resolve the issue. States Impacted: New York
Posted Sep 02, 2026 - 12:02 EDT
This incident affected: HHAeXchange (System/Portal).