System outage for: Alabama, Michigan, Minnesota, Mississippi, New Jersey, Texas, West Virginia.

Incident Report for HHAeXchange

Resolved

The earlier system performance and login issues have been resolved. Platform access and performance are operating normally. Thank you for your patience.
Posted Jan 16, 2026 - 13:22 EST

Monitoring

Mitigations have been applied and we continue to monitor the system for any changes
Posted Jan 16, 2026 - 11:09 EST

Update

HHA+ mobile app is now stable. Users logging into the portal are still experiencing intermittent login issues. Should you experience this simply refresh your browser and try again.
Posted Jan 16, 2026 - 10:45 EST

Update

Users are now able to intermittently login to the Portal and no issues logging into the HHA+ mobile app. The technical team continues to investigate the issue.
Posted Jan 16, 2026 - 10:29 EST

Update

Incident has been escalated to an outage. Users will not be able to login to the portal and Caregivers will not be able to login to the mobile app.
Posted Jan 16, 2026 - 10:13 EST

Investigating

Intermittent login issues have also been identified. The team continues to investigate the issue.
Posted Jan 16, 2026 - 10:05 EST

Update

Slowness has also been identified to our HHA+ Mobile App. The technical team continues to remedy the issue.
Posted Jan 16, 2026 - 09:52 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 16, 2026 - 09:43 EST

Update

We are continuing to investigate this issue.
Posted Jan 16, 2026 - 09:28 EST

Investigating

Some agencies have reported intermittent slowness in the HHAeXchange system. The technical team is investigating.
States Impacted: Alabama, Michigan, Minnesota, Mississippi, New Jersey, Texas, West Virginia.
Posted Jan 16, 2026 - 09:12 EST
This incident affected: HHAeXchange (System/Portal, Mobile App for Caregiver).