System Notification: Caregiver Profile Notes Issue

Incident Report for HHAeXchange

Resolved

This incident has been resolved.
Posted Jun 23, 2025 - 09:01 EDT

Identified

We’ve identified an issue affecting caregiver profile updates. When entering a note, the pop-up window may not close as expected, which can make it appear that the note hasn’t saved.

What you need to know:
In most cases, the note is saved successfully. To confirm, simply click “Save” and refresh the page—you should see your note appear as expected.

Our team is actively working to resolve this behavior and ensure a seamless experience moving forward. We’ll provide an update as soon as the issue is fully resolved.
Posted Jun 20, 2025 - 14:17 EDT
This incident affected: System/Portal.