The outage and fallout checks have been resolved. Please note: * The outage to our systems took place roughly between 1:00 AM ET and 5:30 AM ET due to a 3rd hosting service outage. * IVR calls and Mobile clock in/out during the outage were not recorded. * IVR calls outside of the outage window are being captured however please allow some time as processing is delayed.
Posted Oct 20, 2025 - 08:40 EDT
Monitoring
IVR calls are being captured, however please allow for some time as processing of the calls are delayed.
Posted Oct 20, 2025 - 08:19 EDT
Identified
We have identified an issue with IVR calls due the outage that was experienced. We are investigating to provide further updates.
Posted Oct 20, 2025 - 07:01 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 06:09 EDT
Update
We are continuing to work on a fix and will provide updates as progress is made.
Posted Oct 20, 2025 - 04:13 EDT
Identified
We are currently experiencing a critical outage impacting user logins across all HHAeXchange production environments today. Users are unable to authenticate or access any services at this time. Our engineering teams are actively investigating and will share updates as soon as more information is available.
Posted Oct 20, 2025 - 03:53 EDT
This incident affected: System/Portal, Reports, Electronic Visit Verification (EVV) / Phone System (IVR), Mobile App for Caregiver, and PreBilling/Billing/Payroll.