System Outage

Incident Report for HHAeXchange

Resolved

Access to the HHAeXchange Platform has been restored and you should now be able to login normally.
We apologize for the inconvenience earlier today and appreciate your patience while our teams worked to resolve the issue.
Posted Jun 04, 2026 - 09:52 EDT

Update

The technical team is actively working on resolving the issue. During this time, you will have intermittent issues logging into the portal. We thank you for your patience while we work to get you back online.
Posted Jun 04, 2026 - 09:41 EDT

Identified

Agencies have reported issues logging in to the HHAeXchange system today. The technical team is aware and working to resolve the issue
Posted Jun 04, 2026 - 09:17 EDT
This incident affected: HHAeXchange (System/Portal).