GPS Coordinates Not Displaying on Call Dashboard

Incident Report for HHAeXchange

Resolved

The incident has been resolved, and GPS coordinates are now displaying correctly on the call dashboard. We thank you for your patience.
Posted Jul 23, 2026 - 12:08 EDT

Identified

We have identified an issue where GPS coordinates from your Caregiver's clock-in/outs are not being displayed on the call dashboard. We are actively working to resolve this issue. Please note, coordinates have not been lost and will be restored.
States Impacted: Arkansas, Florida, Illinois, North Carolina, Pennsylvania, West Virginia.
Posted Jul 23, 2026 - 11:03 EDT
This incident affected: HHAeXchange (System/Portal).