Intermittent System Outage

Incident Report for HHAeXchange

Identified

We have validated that portal access has been restored however HHA+ mobile users are still experiencing intermittent issues. The team continues to investigate.
Posted Jun 05, 2026 - 17:19 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 05, 2026 - 16:24 EDT

Update

The technical team is continuing their investigation and work to remedy the issue. We thank you for your patience.
Posted Jun 05, 2026 - 15:34 EDT

Update

The technical team is continuing their investigation and work to remedy the issue. We thank you for your patience.
Posted Jun 05, 2026 - 15:05 EDT

Update

The technical team is continuing their investigation and work to remedy the issue. We thank you for your patience.
Posted Jun 05, 2026 - 14:40 EDT

Update

The technical team is continuing their investigation and work to remedy the issue. We thank you for your patience.
Posted Jun 05, 2026 - 14:20 EDT

Update

The technical team is continuing their investigation and work to remedy the issue. We thank you for your patience.
Posted Jun 05, 2026 - 14:01 EDT

Update

The technical team is continuing their investigation and work to remedy the issue. We thank you for your patience.
Posted Jun 05, 2026 - 13:40 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 05, 2026 - 13:40 EDT

Update

The technical team is continuing their investigation and work to remedy the issue. We thank you for your patience.
Posted Jun 05, 2026 - 13:20 EDT

Update

The technical team is continuing their investigation and work to remedy the issue. We thank you for your patience.
Posted Jun 05, 2026 - 12:57 EDT

Update

The technical team is continuing their investigation and work to remedy the issue. We thank you for your patience.
Posted Jun 05, 2026 - 12:36 EDT

Update

The technical team is continuing their investigation and work to remedy the issue.
Posted Jun 05, 2026 - 12:16 EDT

Identified

Some agencies have reported issues logging into the HHAeXchange portal and the HHA+ mobile app today. The technical team is aware and working to resolve the issue. If you encounter this issue some users have found success in clearing their cache and trying again.
We apologize for the inconvenience.
Posted Jun 05, 2026 - 11:52 EDT
This incident affects: HHAeXchange (Mobile App for Caregiver).