Non Home Care Portal System Outage

Incident Report for HHAeXchange

Resolved

HHAeXchange has addressed and resolved the outage experienced earlier on the Non Home Care Portal.
Posted Jan 19, 2026 - 10:53 EST

Identified

We are receiving reports of errors while logging to the Non Home Care Portal system today. Our technical team is aware and working to resolve the issue.
Posted Jan 19, 2026 - 10:42 EST
This incident affected: HHAeXchange (System/Portal).