System Outage

Incident Report for HHAeXchange

Resolved

At this point we have added further safeguards to ensure system stability. We again apologize for the inconvenience and thank you for your patience.
Posted Mar 25, 2026 - 11:31 EDT

Monitoring

A fix has been implemented, and login functionality has been restored. We are continuing to monitor the situation. We thank you for your patience during this time.
Posted Mar 25, 2026 - 09:45 EDT

Identified

Agencies have reported issues logging in to the HHAeXchange system today. The technical team is aware and working to resolve the issue.
Impacted Market: New York
Posted Mar 25, 2026 - 09:32 EDT
This incident affected: HHAeXchange (System/Portal, Reports, PreBilling/Billing/Payroll).