HHAeXchange IVR System Issue

Incident Report for HHAeXchange

Resolved

The fix has been deployed and observed as fully resolving the issue. We apologize for the inconvenience this has caused.
Posted Apr 02, 2026 - 17:25 EDT

Identified

We have identified the issue and are currently applying a fix across all impacted markets. We will update you once we have completed our work. In the meantime, thank you for your patience.
Impacted Market: All
Posted Apr 02, 2026 - 16:13 EDT

Investigating

We’re aware of intermittent issues with our IVR system and are working closely with our vendor to resolve them.
If your caregiver experiences a failed call, please have them wait 3 minutes and try again.
We will provide an update as soon as this is resolved. We apologize for the inconvenience and appreciate your patience.
Impacted Market: New York
Posted Apr 01, 2026 - 16:22 EDT
This incident affected: HHAeXchange (Electronic Visit Verification (EVV) / Phone System (IVR)).