Mobile Issue - Delay in Mobile App Clock In/Out Reflecting on the Call Dashboard

Incident Report for HHAeXchange

Resolved

The delay has been resolved by our technical team. Mobile app clock in/out will appear on the call dashboard in near real time. We thank you for your patience.
Posted Sep 12, 2025 - 11:31 EDT

Identified

Please note that we are now seeing delays of up to 90 minutes on mobile app clock in/out data. The technical team has identified and continues to work to resolve the issue.
Posted Sep 12, 2025 - 10:03 EDT

Investigating

HHAeXchange has observed an issue where some mobile app clock in/out activity is being delayed in reflecting on the call dashboard. The clock in/out data is not lost simply delayed in reflecting on the dashboard by 30-40 minutes. The technical team is investigating
Posted Sep 12, 2025 - 09:05 EDT
This incident affected: System/Portal and Mobile App for Caregiver.