Support Phone Line and Chat Experiencing Intermittent Outage

Incident Report for HHAeXchange

Resolved

The support chat and call functions have been fully restored. We thank you for your patience.
Posted Jun 26, 2026 - 17:01 EDT

Monitoring

We are aware of a vendor outage that is causing phone calls and chats with our support teams to intermittently drop. Should you experience this issue simply re-dial or restart your browser. We will update you once this issue has been resolved. Thank you for your patience.
Posted Jun 26, 2026 - 11:21 EDT
This incident affected: Call Center.