Intermittent System Outage

Incident Report for HHAeXchange

Resolved

This issue has been resolved, and login access has returned to normal. We apologize for the inconvenience and appreciate your patience while we worked to restore service.
Posted Jan 26, 2026 - 17:34 EST

Monitoring

A fix has been implemented, and you are now able to login consistently. We are monitoring the fix to ensure full resolution.
Posted Jan 26, 2026 - 17:11 EST

Update

We continue to investigate. If you do encounter a login issue, be sure to try again as it appears the login issues are intermittent.
Posted Jan 26, 2026 - 17:05 EST

Update

We continue to investigate. If you do encounter a login issue, be sure to try again as it appears the login issues are intermittent.
Posted Jan 26, 2026 - 16:57 EST

Investigating

Agencies have reported issues logging in to the HHAeXchange system today. The technical team is aware and working to resolve the issue.
States Impacted: Alabama, Michigan, Minnesota, Mississippi, New Jersey, Texas, West Virginia.
Posted Jan 26, 2026 - 16:34 EST
This incident affected: HHAeXchange (System/Portal, Reports, Application Programming Interfaces (API), Mobile App for Caregiver, PreBilling/Billing/Payroll).