Non-Home Care Portal System Outage

Incident Report for HHAeXchange

Resolved

This incident has been resolved.
Posted Feb 19, 2026 - 06:32 EST

Update

We are continuing to work on a fix for this issue.
Posted Feb 19, 2026 - 05:54 EST

Update

We are continuing to work on a fix for this issue.
Posted Feb 19, 2026 - 05:20 EST

Update

We are continuing to work on a fix for this issue.
Posted Feb 19, 2026 - 04:58 EST

Identified

We are receiving reports of errors while logging to the Non-Home Care Portal system today. Our technical team is aware and working to resolve the issue.
Posted Feb 19, 2026 - 04:29 EST
This incident affected: HHAeXchange (System/Portal).