Intermittent System Slowness

Incident Report for HHAeXchange

Resolved

The degraded performance has been resolved. We thank you for your patience.
Posted Oct 29, 2025 - 15:40 EDT

Update

We are continuing to investigate this issue.
Posted Oct 29, 2025 - 15:07 EDT

Update

We are continuing to investigate this issue.
Posted Oct 29, 2025 - 13:27 EDT

Investigating

Some agencies have reported intermittent slowness in the HHAeXchange system. This slowness has been seen when users attempt to log into the portal but also with general navigation and search results. The technical team is investigating.
Posted Oct 29, 2025 - 12:35 EDT
This incident affected: System/Portal.