Visit Processing Delay

Incident Report for HHAeXchange

Update

We’re currently experiencing delays in visit processing, and our team is actively working to resolve this as quickly as possible.

If you’re seeing visits with a status of canceled, this is temporary and no action is needed—we will be reprocessing those visits.

We’ll continue to keep you updated as progress is made. Thank you for your patience and understanding—we truly appreciate it.
Posted Mar 20, 2026 - 13:01 EDT

Identified

We’re currently experiencing delays in visit processing, and our team is actively working to resolve this as quickly as possible.

If you’ve already submitted a visit and don’t see it yet, no action is needed—we’re still processing it.

We’ll continue to keep you updated as progress is made. Thank you for your patience and understanding—we truly appreciate it.

Impacted Markets: Illinois, Michigan, Minnesota, Mississippi, New Jersey, Oklahoma, West Virginia
Posted Mar 19, 2026 - 10:33 EDT
This incident affects: HHAeXchange (Application Programming Interfaces (API)).