Portal, IVR, Mobile, & Technical Customer Care Support Call Disruption Due to AWS Outage

Incident Report for HHAeXchange

Resolved

At this moment we are now fully resolved.
Posted Oct 20, 2025 - 17:54 EDT

Update

We have observed our systems have recovered and will continue to monitor to ensure full resolution.
Posted Oct 20, 2025 - 17:09 EDT

Update

We understand the impact this issue is having on your operations and want to assure you that resolving this matter is our highest priority. Our AWS is actively working to mitigate this issue with urgency. While we do not have a definitive ETA at this time, we remain committed to full resolution and deeply appreciate your patience as we work through this situation. We will continue to provide updates every hour or sooner as new information becomes available.
Posted Oct 20, 2025 - 16:21 EDT

Update

We understand the impact this issue is having on your operations and want to assure you that resolving this matter is our highest priority. Our AWS is actively working to mitigate this issue with urgency. While we do not have a definitive ETA at this time, we remain committed to full resolution and deeply appreciate your patience as we work through this situation. We will continue to provide updates every hour or sooner as new information becomes available.
Posted Oct 20, 2025 - 15:22 EDT

Update

We understand the impact this issue is having on your operations and want to assure you that resolving this matter is our highest priority. Our AWS is actively working to mitigate this issue with urgency. While we do not have a definitive ETA at this time, we remain committed to full resolution and deeply appreciate your patience as we work through this situation. We will continue to provide updates every hour or sooner as new information becomes available.
Posted Oct 20, 2025 - 14:15 EDT

Update

It has now been observed that due to the AWS outage users are intermittently unable to log into the portal. We continue to provide updates as they become available.
Posted Oct 20, 2025 - 13:03 EDT

Update

We understand the impact this issue is having on your operations and want to assure you that resolving this matter is our highest priority. Our AWS is actively working to mitigate this issue with urgency. While we do not have a definitive ETA at this time, we remain committed to full resolution and deeply appreciate your patience as we work through this situation. We will continue to provide updates every hour or sooner as new information becomes available.
Posted Oct 20, 2025 - 12:39 EDT

Update

Update: Phone Lines Down – Technical Customer Care & IVR Impacted by AWS Outage

Due to the ongoing nationwide AWS outage, both Technical Customer Care (TCC) and IVR phone lines are currently down. What this means for you:
- Caregivers are unable to clock in or out through IVR
- TCC phone support is experiencing call disruptions

We are actively monitoring the situation and assessing the impact. In the meantime, if you need assistance, please use the following resources:
Knowledge Base: https://knowledge.hhaexchange.com/enterprise/Content/Home/Home-N.htm
Support Portal: https://hhaexchange.my.site.com/s/login/

While we work to resolve this outage, there may be additional service impacts. We’re actively addressing them and will continue to provide updates as they occur.
Posted Oct 20, 2025 - 11:46 EDT

Monitoring

Due to the ongoing AWS outage, some Technical Customer Care support calls may not be connecting successfully. We're actively monitoring the situation and assessing the impact.

In the meantime, if you need assistance, please use the following resources:
Knowledge Base: https://knowledge.hhaexchange.com/enterprise/Content/Home/Home-N.htm
Support Portal: https://hhaexchange.my.site.com/s/login/

Thank you for your patience while we work through this.
Posted Oct 20, 2025 - 10:39 EDT
This incident affected: System/Portal, Electronic Visit Verification (EVV) / Phone System (IVR), and Call Center.