Intermittent System Slowness

Incident Report for HHAeXchange

Resolved

We have observed that the performance has recovered. We apologize for the inconvenience this issue has caused to your business, and we are committed to further actions to ensure stability.
Posted Mar 24, 2026 - 16:17 EDT

Monitoring

A fix has been implemented, and we are monitoring to ensure performance issues have been remedied. We sincerely apologize for the inconvenience.
Posted Mar 24, 2026 - 15:45 EDT

Investigating

Some agencies have reported intermittent slowness in the HHAeXchange system. The technical team is investigating. We apologies for the inconvenience and are working to recover our system's performance.
Impacted Markets: New York
Posted Mar 24, 2026 - 15:00 EDT
This incident affected: HHAeXchange (System/Portal).