Mobile Issue - Investigating

Incident Report for HHAeXchange

Resolved

The technical team was able to resolve the issue. We apologize for the inconvenience.
Posted Feb 14, 2026 - 04:32 EST

Update

We are continuing to work on a fix for this issue.
Posted Feb 14, 2026 - 04:26 EST

Update

We are continuing to work on a fix for this issue.
Posted Feb 14, 2026 - 04:14 EST

Identified

HHAeXchange has identified an issue affecting the HHA+ mobile app. While we address this issue, some may experience an inability to log into the HHA+ mobile app. While the technical team works to resolve the issue, please note that offline mode will continue to function for those users who are impacted. If offline mode is not configured for your users we recommend leveraging IVR or manually recording any missed visits.
Posted Feb 14, 2026 - 03:40 EST
This incident affected: HHAeXchange (Mobile App for Caregiver).