Dashboard Loading Issues

Incident Report for HHAeXchange

Resolved

This incident has been resolved.
Posted Mar 28, 2025 - 08:43 EDT

Identified

Some agencies have reported their dashboards have not been loading. The technical team is investigating.
Posted Mar 28, 2025 - 08:19 EDT
This incident affected: Reports.