The login issues have been resolved. We thank you for your patience while we remedied the issue.
Posted May 13, 2026 - 11:38 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 13, 2026 - 11:17 EDT
Investigating
We are still observing failures to login. We apologize for the inconvenience and are continuing to work to provide a full resolution.
Posted May 13, 2026 - 11:00 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 13, 2026 - 10:49 EDT
Update
Updating the list of states impacted. The technical team continues to work to provide a resolution. Thank you for your patience. States Impacted: Alabama, Michigan, Minnesota, Mississippi, New Jersey, New York, Texas, West Virginia, Arkansas, Florida, Illinois, North Carolina, Pennsylvania, West Virginia.
Posted May 13, 2026 - 10:15 EDT
Investigating
After the fix we are observing fewer failures to login however there are still failures to login. If you do encounter a failure to login please try again. We apologize for the inconvenience and are continuing to provide a full resolution.
Posted May 13, 2026 - 09:59 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 13, 2026 - 09:47 EDT
Investigating
Agencies have reported intermittent issues logging in to the HHAeXchange system today. The technical team is aware and working to resolve the issue. We apologies for the inconvenience States Impacted: Alabama, Michigan, Minnesota, Mississippi, New Jersey, Texas, West Virginia, Arkansas, Florida, Illinois, North Carolina, Pennsylvania, West Virginia.
Posted May 13, 2026 - 09:37 EDT
This incident affected: HHAeXchange (System/Portal).