This issue has been resolved. We thank you for your patience as we remedied the issue and apologies for the disruption to your business day.
Posted Sep 08, 2026 - 11:52 EDT
Update
We have found the fix that was deployed is working however it will take time to propagate. Should your caregivers encounter the same error in dialing the IVR line request them to wait a few minutes and try again.
We apologize for the inconvenience.
Posted Sep 08, 2026 - 10:05 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 08, 2026 - 09:41 EDT
Update
A solution has been developed and currently being tested.
Posted Sep 08, 2026 - 09:18 EDT
Identified
HHAeXchange is currently experiencing a telephony system connection issue resulting in failed IVR calls. The technical team is aware and working to resolve the issue. Impacted Market: New York
Posted Sep 08, 2026 - 09:02 EDT
This incident affected: HHAeXchange (Electronic Visit Verification (EVV) / Phone System (IVR)).