System Outage

Incident Report for HHAeXchange

Resolved

This incident has been resolved.
Posted Feb 19, 2026 - 01:50 EST

Identified

Agencies have reported issues logging in to the HHAeXchange system today. The technical team is aware and working to resolve the issue.
States Impacted: Alabama, Michigan, Minnesota, Mississippi, New Jersey, Texas, West Virginia.
Posted Feb 19, 2026 - 01:46 EST
This incident affected: HHAeXchange (System/Portal, Reports, Application Programming Interfaces (API), Mobile App for Caregiver, PreBilling/Billing/Payroll).